Module: Thin

Module Thin < RuntimeError

(in files lib/thin/backends/base.rb lib/thin/backends/swiftiply_client.rb lib/thin/backends/tcp_server.rb lib/thin/backends/unix_server.rb lib/thin/command.rb lib/thin/connection.rb lib/thin/controllers/cluster.rb lib/thin/controllers/controller.rb lib/thin/controllers/service.rb lib/thin/daemonizing.rb lib/thin/headers.rb lib/thin/logging.rb lib/thin/request.rb lib/thin/response.rb lib/thin/runner.rb lib/thin/server.rb lib/thin/stats.rb lib/thin/statuses.rb lib/thin/version.rb lib/thin.rb )

For Rails pre Rack (2.3)

Methods

Public Class linux?()

    # File lib/thin/version.rb, line 25
25:   def self.linux?
26:     RUBY_PLATFORM =~ /linux/
27:   end

Public Class ruby_18?()

    # File lib/thin/version.rb, line 29
29:   def self.ruby_18?
30:     RUBY_VERSION =~ /^1\.8/
31:   end

Public Class win?()

    # File lib/thin/version.rb, line 21
21:   def self.win?
22:     RUBY_PLATFORM =~ /mswin|mingw/
23:   end